polecenia routing EIGRP.txt

(2 KB) Pobierz
polecenia CCNP Routing 

EIGRP

R1(config)# router eigrp 1   
R1(config-router)# network 10.0.0.0
R1(config-router)# no auto-summary 

R1# show ip eigrp interfaces 
R1# show ip eigrp neighbors
R1# show ip eigrp topology
R1# show ip route eigrp

To see the full effect of EIGRP equal-cost load balancing, temporarily disable CEF and route caching so that all IP packets are processed individually and not fast-switched by CEF.

R3(config)# no ip cef
R3(config)# interface S0/0/0
R3(config-if)# no ip route-cache
R3(config-if)# interface S0/0/1
R3(config-if)# no ip route-cache

R3# show ip eigrp topology all-links


Summaryzacja Eigrp 
R1(config)# router eigrp 100
R1(config-router)# auto-summary

The EIGRP auto-summary command turns auto-summarization on globally on a router, but you can also configure summary routes manually with the interface-level command ip summary-address eigrp as network mask.

R3(config)# interface Serial 0/0/1
R3(config-if)# ip summary-address eigrp 100 192.168.0.0 255.255.224.0


R1(config)# ip default-network 172.31.0.0


Frame Relay 


interface Serial0/0/0
description FR to HQ
no ip address
encapsulation frame-relay ietf
clock rate 128000
frame-relay lmi-type cisco
frame-relay intf-type dce
frame-relay route 102 interface Serial0/0/1 201
frame-relay route 103 interface Serial0/1/0 301


Brodcast 

HQ# conf t
HQ(config)# interface serial 0/0/1
HQ(config-if)# ip address 172.16.124.1 255.255.255.248
HQ(config-if)# encapsulation frame-relay ietf
HQ(config-if)# no frame-relay inverse-arp
HQ(config-if)# frame-relay map ip 172.16.124.2 102 broadcast    - po?aczenie jako brodcast 
HQ(config-if)# frame-relay map ip 172.16.124.3 103 broadcast


non-broadcast EIGRP mode

HQ(config)# router eigrp 1
HQ(config-router)# neighbor 172.16.124.2 serial 0/0/1  - na interfejs jest puszczane 
HQ(config-router)# neighbor 172.16.124.3 serial 0/0/1


Configure authentication keys EIGRP 

key chain R1chain
 key 1
 key-string firstkey
 accept-lifetime 04:00:00 Jan 1 2006 infinite
 send-lifetime 04:00:00 Jan 1 2006 04:01:00 Jan 1 2006
key 2
 key-string secondkey
 accept-lifetime 04:00:00 Jan 1 2006 infinite
 send-lifetime 04:00:00 Jan 1 2006 infinite
interface FastEthernet0/0
  ip address 172.16.1.1 255.255.255.0
interface Serial0/0/1
  bandwidth 64
  ip address 192.168.1.101 255.255.255.224
  ip authentication mode eigrp 100 md5
  ip authentication key-chain eigrp 100 R1chain
router eigrp 100
  network 172.16.1.0 0.0.0.255
  network 192.168.1.0


R1# show ip eigrp interfaces detail



Manipulate EIGRP timers


R1# conf t
R1(config)# interface serial 0/0/0
R1(config-if)# ip hello-interval eigrp 1 2
R1(config-if)# ip hold-time eigrp 1 8


R1# show ip eigrp 1 interfaces detail serial 0/0/0




























Zgłoś jeśli naruszono regulamin